[elvin-discuss] Re: Elvin spec

Ian Lister ilister at mantara.com
Thu Dec 21 17:48:53 CST 2006

On Fri, 22 Dec 2006, David Arnold wrote:
> I *think* I prefer that we use a name that allows a positive change away
> from the default.

My initial reaction is that that's less important than just having the 
option expressed in a positive sense (i.e. if it's on by default, that's 
fine), but I think that probably comes from a GUI perspective where you 
can have all the possible options presented and some enabled by default, 
which isn't quite the same as a properties table in which options need to 
be set explicitly.

> So, while I like both of
>  Matt>    TCP.Queue-Packets TCP.Coalesce-Packets
> too, I think I prefer
>  >> TCP.Send-Packets-Immediately
> because it's something you can turn _on_.

Likewise, but I think it's a little unnecessarily verbose, and it could be 
"TCP.Send-Immediately" or "TCP.Immediate-Send" without any loss of 

>  Matt> I'm planning to allow defaults for all of the connection options
>  Matt> to be set in the Avis config file. e.g. "Receive-Queue.Drop-
>  Matt> Policy=fail". I'm also going to make the matching
>  Matt> case-independent.  Sound like a sane thing to do?
> I think that's sane.
> It's also, handily, Java's default properties file semantics, isn't it?  :-)

How sensible of Java... ;-)


More information about the elvin-discuss mailing list